Thursday, August 13, 2009

Ubuntu Postgres 8.3.6 Missing Library

Recently, I encounter missing library when I install Postgres 8.3.6 on Ubuntu 2.6.28-13-generic build.

I do the following as a quick fix

1. missing libssl.so.4 -> ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.4
2. missing libcrypto.so.4 -> ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.4
3. missing libreadline.so.4 -> ln -s /lib/libreadline.so.5 /lib/libreadline.so.4
4. missing libtermcap.so.2 -> ln -s /lib/libncurses.so.5 /lib/libtermcap.so.2

after creating the above soft link, my postgres starts and work perfectly.

No comments:

Post a Comment

Facebook - Control privacy setting of liked page

By default, Facebook displayed your liked page to public. It is the user responsibility to adjust the privacy setting. And in my opinion, F...